edgeMate Method
Return a walker (new or reused) at the edge mate of this walker's edge.
- The returned walker has undefined edgeIndex if:
- the instance is at a boundary edge, i.e., there is no facet on the other side, or
- the instance has undefined edgeIndex.
edgeMate(result?: IndexedPolyfaceWalker): IndexedPolyfaceWalker
Parameter | Type | Description |
---|---|---|
result | IndexedPolyfaceWalker | optional receiver to modify and return. May be the same as this to move the instance walkerto the new location and return it. |
Returns - IndexedPolyfaceWalker
Defined in
- polyface/IndexedPolyfaceWalker.ts Line 261
Last Updated: 21 February, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.