createAtVisitor MethodStatic
Create a walker at the facet specified by a visitor.
createAtVisitor(visitor: IndexedPolyfaceVisitor, offsetWithinFacet: number0): IndexedPolyfaceWalker
Parameter | Type | Description |
---|---|---|
visitor | IndexedPolyfaceVisitor | visitor whose currentReadIndex identifies the facet. |
offsetWithinFacet | number | optional 0-based offset within the face loop of the facet (default 0). This allows the caller to start the walker at a particular edge of the facet. |
Returns - IndexedPolyfaceWalker
Defined in
- polyface/IndexedPolyfaceWalker.ts Line 150
Last Updated: 21 February, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.