clone Method
Create a new IndexedPolyfaceWalker from the instance.
- The returned walker refers to the same polyface.
- If
edgeIndex
is undefined, the returned walker refers to the same edge as the instance. - If
edgeIndex
is defined and valid, the returned walker refers to this edge. - If
edgeIndex
is defined but invalid, return undefined.
clone(edgeIndex?: number): undefined | IndexedPolyfaceWalker
Parameter | Type | Description |
---|---|---|
edgeIndex | number |
Returns - undefined | IndexedPolyfaceWalker
Defined in
- polyface/IndexedPolyfaceWalker.ts Line 161
Last Updated: 21 February, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.