createSubsetVisitor MethodStatic
Create a visitor for iterating a subset of the facets of polyface
.
createSubsetVisitor(polyface: IndexedPolyface, activeFacetIndices: number[], numWrap: number0): IndexedPolyfaceSubsetVisitor
Parameter | Type | Description |
---|---|---|
polyface | IndexedPolyface | reference to the client polyface, supplying facets |
activeFacetIndices | number[] | array of indices of facets in the client polyface to visit. This array is cloned. |
numWrap | number | number of vertices replicated in the visitor arrays to facilitate simpler caller code. Default is zero. |
Returns - IndexedPolyfaceSubsetVisitor
Defined in
- polyface/IndexedPolyfaceVisitor.ts Line 230
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.