terminateFacet Method
Announce the end of construction of a facet.
- Optionally check for:
- Same number of indices among all active index arrays -- point, normal, param, color
- All indices for the latest facet are within bounds of the respective data arrays.
- In error cases, all index arrays are trimmed back to the size when previous facet was terminated.
- A return value of
undefined
is normal. Otherwise, a string array of error messages is returned.
terminateFacet(validateAllIndices: booleantrue): undefined | string[]
Parameter | Type | Description |
---|---|---|
validateAllIndices | boolean |
Returns - undefined | string[]
Defined in
- polyface/Polyface.ts Line 524
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.