create MethodStatic

Create an empty facet set with coordinate and index data to be supplied later.

create(needNormals: booleanfalse, needParams: booleanfalse, needColors: booleanfalse, twoSided: booleantrue): IndexedPolyface

Parameter Type Description
needNormals boolean true to allocate empty normal data and index arrays; false (default) to leave undefined.
needParams boolean true to allocate empty uv parameter data and index arrays; false (default) to leave undefined.
needColors boolean true to allocate empty color data and index arrays; false (default) to leave undefined.
twoSided boolean true (default) if the facets are to be considered viewable from the back; false if they are amenable to backface culling.

Returns - IndexedPolyface

Defined in

Last Updated: 04 April, 2025