addIndexedPolyface Method
Add facets from source
to this
polyface.
- Optionally reverse facet indices as per
PolyfaceData.reverseIndicesSingleFacet()
withpreserveStart = false
and invert source normals. - Optionally apply a
transform
to points and normals. - Will only copy param, normal, color, and face data if we are already tracking them AND/OR the source contains them.
addIndexedPolyface(source: IndexedPolyface, reversed: boolean, transform: Transform): void
Parameter | Type | Description |
---|---|---|
source | IndexedPolyface | |
reversed | boolean | |
transform | Transform |
Returns - void
Defined in
- polyface/Polyface.ts Line 223
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.