addPath Method
Push edges all around a facet, returning to vertexArray[0].
addPath(vertexArray: number[], facetIndex: number, closeLoop: booleantrue): void
Parameter | Type | Description |
---|---|---|
vertexArray | number[] | array of vertex indices around facet |
facetIndex | number | facet index |
closeLoop | boolean | true to add an edge from last to first vertex. |
Returns - void
Defined in
- polyface/IndexedEdgeMatcher.ts Line 140
Last Updated: 18 January, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.