setParamDistanceRangeFromNewFaceData Method
Sets the param and paramDistance range of this FacetFaceData based on the newly terminated facets that make it up. Takes the polyface itself, and facetIndex range to be included in the face (facetStart <= facetIndex < facetEnd). Returns true on success, false otherwise.
setParamDistanceRangeFromNewFaceData(polyface: IndexedPolyface, facetStart: number, facetEnd: number): boolean
Parameter | Type | Description |
---|---|---|
polyface | IndexedPolyface | |
facetStart | number | |
facetEnd | number |
Returns - boolean
Defined in
- polyface/FacetFaceData.ts Line 88
Last Updated: 21 February, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.