getNormal Method
Get normal interpolated from facet data.
getNormal(facetNormals?: IndexedXYZCollection, facetVertices?: IndexedXYZCollection, distanceTolerance: numberGeometry.smallMetricDistance): undefined | Vector3d
@returns reference to cached normal
Parameter | Type | Description |
---|---|---|
facetNormals | IndexedXYZCollection | used to compute the normal cache |
facetVertices | IndexedXYZCollection | used to compute the barycentric coordinate cache |
distanceTolerance | number | used to compute the barycentric coordinate cache |
Returns - undefined | Vector3d
reference to cached normal
Defined in
- polyface/FacetLocationDetail.ts Line 438
Last Updated: 23 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.