claimPolyface Method
Return the computed facets from the selected builder.
claimPolyface(selector: "0" | "1", fixup: boolean, tolerance: numberGeometry.smallMetricDistance): undefined | IndexedPolyface
Parameter | Type | Description |
---|---|---|
selector | "0" | "1" | the polyface to return: 0 - builderA (typically inside facets), 1 - builderB (typically outside facets) |
fixup | boolean | whether to clean up the polyface |
tolerance | number | compression tolerance (default smallMetricDistance). |
Returns - undefined | IndexedPolyface
Defined in
- polyface/PolyfaceClip.ts Line 80
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.