intersect3Planes MethodStatic
Compute the intersection of three planes.
intersect3Planes(xyzA: Point3d, normalA: Vector3d, xyzB: Point3d, normalB: Vector3d, xyzC: Point3d, normalC: Vector3d, result?: Vector3d): undefined | Vector3d
@returns intersection point of the three planes (as a Vector3d), or undefined if at least two planes are parallel.
Parameter | Type | Description |
---|---|---|
xyzA | Point3d | point on the first plane |
normalA | Vector3d | normal of the first plane |
xyzB | Point3d | point on the second plane |
normalB | Vector3d | normal of the second plane |
xyzC | Point3d | point on the third plane |
normalC | Vector3d | normal of the third plane |
result | Vector3d | optional result |
Returns - undefined | Vector3d
intersection point of the three planes (as a Vector3d), or undefined if at least two planes are parallel.
Defined in
- numerics/SmallSystem.ts Line 347
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.