inertiaProductsToPrincipalAxes MethodStatic
Compute principal axes from inertial products.
- The radii of gyration are sorted smallest to largest.
- Hence x axis is long direction.
- Hence planar data generates large moment as Z.
inertiaProductsToPrincipalAxes(origin: XYZ, inertiaProducts: Matrix4d): undefined | MomentData
Parameter | Type | Description |
---|---|---|
origin | XYZ | The origin used for the inertia products. |
inertiaProducts | Matrix4d | The inertia products: sums or integrals of [xx,xy,xz,xw; yx,yy, yz,yw; zx,zy,zz,zw; wx,wy,wz,w]. |
Returns - undefined | MomentData
Defined in
- geometry4d/MomentData.ts Line 182
Last Updated: 18 January, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.