create MethodStatic
Create moments with optional origin.
- origin and needOrigin are quirky.
- (undefined, true) sets up to use first incoming point as origin.
- (origin) sets up to use that durable origin, set needsOrigin flag false
- (origin, true) the "true" is meaningless
- (undefined, false) makes 000 the durable origin
create(origin?: Point3d, needOrigin: booleanfalse): MomentData
Parameter | Type | Description |
---|---|---|
origin | Point3d | |
needOrigin | boolean |
Returns - MomentData
Defined in
- geometry4d/MomentData.ts Line 120
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.