accumulateXYProductsInCentroidalFrame Method

  • Assemble XX, YY, XY products into a full matrix form [xx,xy,0,0; xy,yy,0,0;0,0,0,0;0,0,0,1].
  • Sandwich this between transforms with columns [vectorU, vectorV, 0000, origin]. (Column weights 0001) (only xy parts of vectors).
  • scale by detJ for the xy-only determinant of the vectors.

accumulateXYProductsInCentroidalFrame(productXX: number, productXY: number, productYY: number, area: number, origin: Readonly<WritableXAndY>, vectorU: Readonly<WritableXAndY>, vectorV: Readonly<WritableXAndY>): void

Parameter Type Description
productXX number  
productXY number  
productYY number  
area number Area in caller's system.
origin Readonly<WritableXAndY> Caller's origin.
vectorU Readonly<WritableXAndY> Caller's U axis (not necessarily unit).
vectorV Readonly<WritableXAndY> Caller's V axis (not necessarily unit).

Returns - void

Defined in

Last Updated: 18 January, 2025