accumulateTriangleMomentsXY Method
compute moments of a triangle from the origin to the given line. Accumulate them to this.sums.
- If
pointA
is undefined, usethis.origin
as pointA. - If
this.needOrigin
is set, pointB is used
accumulateTriangleMomentsXY(pointA: Readonly<WritableXAndY>, pointB: Readonly<WritableXAndY>, pointC: Readonly<WritableXAndY>): void
Parameter | Type | Description |
---|---|---|
pointA | Readonly<WritableXAndY> | |
pointB | Readonly<WritableXAndY> | |
pointC | Readonly<WritableXAndY> |
Returns - void
Defined in
- geometry4d/MomentData.ts Line 302
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.