createBoxToBox MethodStatic
Create a mapping that scales and translates (no rotation) from box A to box B
createBoxToBox(lowA: Point3d, highA: Point3d, lowB: Point3d, highB: Point3d, result?: Matrix4d): undefined | Matrix4d
Parameter | Type | Description |
---|---|---|
lowA | Point3d | low point of box A |
highA | Point3d | high point of box A |
lowB | Point3d | low point of box B |
highB | Point3d | high point of box B |
result | Matrix4d |
Returns - undefined | Matrix4d
Defined in
- geometry4d/Matrix4d.ts Line 199
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.