addTranslationSandwichInPlace Method
Add (in place) scaleAB*AT where
- A is a pure translation with final column [x,y,z,1]
- B is the given
matrixB
- AT is the transpose of A.
- scale is a multiplier.
addTranslationSandwichInPlace(matrixB: Matrix4d, ax: number, ay: number, az: number, scale: number): void
Parameter | Type | Description |
---|---|---|
matrixB | Matrix4d | the middle matrix. |
ax | number | x part of translation |
ay | number | y part of translation |
az | number | z part of translation |
scale | number | scale factor for entire product |
Returns - void
Defined in
- geometry4d/Matrix4d.ts Line 700
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.