chainDistanceToAccurateChildFraction Method

Convert the given chainDistance to a fraction along this childCurve using moveSignedDistanceFromFraction.

chainDistanceToAccurateChildFraction(chainDistance: number, allowExtrapolation?: boolean): number

@returns fraction local to the relevant chain primitive corresponding to the chain position at chainDistance.

Parameter Type Description
chainDistance number signed distance along the chain.
allowExtrapolation boolean whether to extrapolate off the start of the chain if chainDistance is negative,
or off the end of the chain if chainDistance is more than chainLength. Extending the chain in this manner
may result in significant inaccuracy, especially for negative distances.

Returns - number

fraction local to the relevant chain primitive corresponding to the chain position at chainDistance.

Defined in

Last Updated: 21 November, 2024