closestPoint Method
Return the closest point on the contained curves.
closestPoint(spacePoint: Point3d, extend: VariantCurveExtendParameterfalse, result?: CurveLocationDetail): undefined | CurveLocationDetail
@returns details of the closest point.
Parameter | Type | Description |
---|---|---|
spacePoint | Point3d | point in space. |
extend | VariantCurveExtendParameter | compute the closest point to the path extended according to variant type: * false: do not extend the path * true: extend the path at both start and end * CurveExtendOptions: extend the path in the specified manner at both start and end * CurveExtendOptions[]: entry applies to path start; second, to path end; any other entries ignored |
result | CurveLocationDetail | optional pre-allocated detail to populate and return. |
Returns - undefined | CurveLocationDetail
details of the closest point.
Defined in
- curve/Path.ts Line 86
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.