create MethodStatic
Create a loop from a variable length list of CurvePrimitives.
- A significant gap between the end of one curve and the start of the next, or between chain start and end, is not bridged and may cause unexpected behavior.
create(...curves: CurvePrimitive[]): Loop
Parameter | Type | Description |
---|---|---|
...curves | CurvePrimitive[] | array of individual curve primitives, assumed to form a closed planar loop. |
Returns - Loop
Defined in
- curve/Loop.ts Line 43
Last Updated: 18 January, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.