createArray MethodStatic

Create a loop from an array of CurvePrimitives.

  • A significant gap between the end of one curve and the start of the next, or between chain start and end, is not bridged and may cause unexpected behavior.

createArray(curves: CurvePrimitive[]): Loop

Parameter Type Description
curves CurvePrimitive[] array of individual curve primitives, assumed to form a closed planar loop.

Returns - Loop

Defined in

Last Updated: 18 January, 2025