mapLocalToGlobalFraction MethodStatic
Convert a segment index and local fraction to a global linestring fraction.
mapLocalToGlobalFraction(index: number, localFraction: number, numSegment: number): number
@returns global fraction f in [0,1] such that the segment is parameterized by index/N <= f <= (index+1)/N.
Parameter | Type | Description |
---|---|---|
index | number | index of segment being evaluated |
localFraction | number | local fraction in [0,1] within the segment |
numSegment | number | number N of segments in the linestring |
Returns - number
global fraction f in [0,1] such that the segment is parameterized by index/N <= f <= (index+1)/N.
Defined in
- curve/LineString3d.ts Line 591
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.