fractionToPointAndDerivative Method
Evaluate a point a fractional position and derivative with respect to fraction along this linestring.
- See
LineString3d
class comments for description of how fraction relates to the linestring points. - At interior corners and the end point, the left derivative is returned; at the start point, the right derivative is returned.
fractionToPointAndDerivative(fraction: number, result?: Ray3d): Ray3d
Parameter | Type | Description |
---|---|---|
fraction | number | fractional position |
result | Ray3d | optional result |
Returns - Ray3d
Defined in
- curve/LineString3d.ts Line 543
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.