emitStrokableParts Method
Emit strokable parts of the curve to a caller-supplied handler. If the stroke options does not have a maxEdgeLength, one stroke is emitted for each segment of the linestring. If the stroke options has a maxEdgeLength, smaller segments are emitted as needed.
emitStrokableParts(handler: IStrokeHandler, options?: StrokeOptions): void
Parameter | Type | Description |
---|---|---|
handler | IStrokeHandler | |
options | StrokeOptions |
Returns - void
Defined in
- curve/LineString3d.ts Line 1156
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.