appendPlaneIntersectionPoints Method
Find intersections with a plane. Intersections within segments are recorded as CurveIntervalRole.isolated Intersections at isolated "on" vertex are recoded as CurveIntervalRole.isolatedAtVertex.
appendPlaneIntersectionPoints(plane: PlaneAltitudeEvaluator, result: CurveLocationDetail[]): number
Parameter | Type | Description |
---|---|---|
plane | PlaneAltitudeEvaluator | |
result | CurveLocationDetail[] |
Returns - number
Defined in
- curve/LineString3d.ts Line 937
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.