appendFractionToPoint Method
Append a suitable evaluation of a curve.
- If the computed point is the same as the last point, nothing is appended.
- Otherwise, the point is appended, as well as the fraction and derivative (if those arrays are present).
appendFractionToPoint(curve: CurvePrimitive, fraction: number): void
Parameter | Type | Description |
---|---|---|
curve | CurvePrimitive | the curve to evaluate. |
fraction | number | the fraction at which to evaluate the curve. |
Returns - void
Defined in
- curve/LineString3d.ts Line 1053
Last Updated: 26 April, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.