appendFractionalStrokePoints Method
Evaluate a curve at uniform fractions. Append the evaluations to this linestring.
appendFractionalStrokePoints(curve: CurvePrimitive, numStrokes: number, fraction0: number0, fraction1: number1, include01: booleantrue): void
Parameter | Type | Description |
---|---|---|
curve | CurvePrimitive | primitive to evaluate. |
numStrokes | number | number of strokes (edges). |
fraction0 | number | starting fraction coordinate |
fraction1 | number | end fraction coordinate |
include01 | boolean | if false, points at fraction0 and fraction1 are omitted. |
Returns - void
Defined in
- curve/LineString3d.ts Line 1090
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.