addMappedStrokesToLineString3D Method
Evaluate strokes at fractions indicated in a StrokeCountMap.
- The map must have an array of component counts corresponding to the segment of this linestring.
- "fractions" in the output are mapped within a0,a1 of the map.componentData
addMappedStrokesToLineString3D(map: StrokeCountMap, destLinestring: LineString3d): number
@returns number of strokes added. 0 if map.componentData
does not match the linestring
Parameter | Type | Description |
---|---|---|
map | StrokeCountMap | = stroke count data. |
destLinestring | LineString3d | = receiver linestring. |
Returns - number
number of strokes added. 0 if map.componentData
does not match the linestring
Defined in
- curve/LineString3d.ts Line 1347
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.