closestPoint Method
Returns a curve location detail with both xyz and fractional coordinates of the closest point.
closestPoint(spacePoint: Point3d, extend: VariantCurveExtendParameter, result?: CurveLocationDetail): CurveLocationDetail
@returns detail, with a
field set to the distance from spacePoint
to the closest point
Parameter | Type | Description |
---|---|---|
spacePoint | Point3d | point in space |
extend | VariantCurveExtendParameter | if false, only return points within the bounded line segment. If true, allow the point to be on the unbounded line that contains the bounded segment. |
result | CurveLocationDetail | optional pre-allocated object to populate and return |
Returns - CurveLocationDetail
detail, with a
field set to the distance from spacePoint
to the closest point
Defined in
- curve/LineSegment3d.ts Line 211
Last Updated: 23 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.