buildRotationalNormalsInLineStrings MethodStatic

Recurse through geometry.children to find linestrings. For each linestring, compute and store the normal of the rotational surface resulting from sweeping the geometry around axis through a positive angle, using:

  • the curve tangent stored in the linestring
  • the axis of rotation
  • a default V vector to be used when the linestring point is close to the axis

buildRotationalNormalsInLineStrings(geometry: AnyCurve, axis: Ray3d, defaultVectorFromAxis: Vector3d): void

Parameter Type Description
geometry AnyCurve profile curve (e.g., linestring, parity region). The orientation of the curve should be such that
the computed normal lies in the same half-space as the rotational sweep direction.
axis Ray3d rotational axis
defaultVectorFromAxis Vector3d default vector perpendicular to axis (e.g., sweepVector)

Returns - void

Defined in

Last Updated: 18 January, 2025