projectedParameterRange Method
Project instance geometry (via dispatch) onto the line of the given ray, and return the extreme fractional parameters of projection.
projectedParameterRange(_ray: Vector3d | Ray3d, _lowHigh?: Range1d): undefined | Range1d
@returns range of fractional projection parameters onto the ray, where 0.0 is start of the ray and 1.0 is the end of the ray.
Parameter | Type | Description |
---|---|---|
_ray | Vector3d | Ray3d | |
_lowHigh | Range1d |
Returns - undefined | Range1d
range of fractional projection parameters onto the ray, where 0.0 is start of the ray and 1.0 is the end of the ray.
Defined in
- curve/CurvePrimitive.ts Line 809
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.