updateIfCloserCurveFractionPointDistance Method
Update or create if closer than current contents.
updateIfCloserCurveFractionPointDistance(curve: CurvePrimitive, fraction: number, point: Point3d, a: number): boolean
@returns true if the given distance is smaller (and hence this detail was updated.)
Parameter | Type | Description |
---|---|---|
curve | CurvePrimitive | candidate curve |
fraction | number | candidate fraction |
point | Point3d | candidate point |
a | number | candidate distance |
Returns - boolean
true if the given distance is smaller (and hence this detail was updated.)
Defined in
- curve/CurveLocationDetail.ts Line 346
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.