createMiteredPipeSections MethodStatic
Create section arcs for mitered pipe.
- At the end of each pipe segment, the pipe is mitered by the plane that bisects the angle between successive centerline segments.
- The section arcs are constructed so that lines between corresponding fractional positions on the arcs are axial lines on the pipes.
- This means that the initial arc's vector0 and vector90 lengths and angular separation are not preserved in the section arcs.
- Circular or elliptical pipe cross sections can be specified by supplying either a radius, a pair of semi-axis
lengths, or an Arc3d:
- For semi-axis length input, x and y correspond to ellipse local axes perpendicular to each other and to the start tangent.
- For Arc3d input, the center is translated to the centerline start point. For best results, ensure this arc is perpendicular to the centerline start tangent.
- This function internally calls createMiteredSweepSections with default options.
createMiteredPipeSections(centerline: IndexedXYZCollection, sectionData: number | Readonly<WritableXAndY> | Arc3d): Arc3d[]
@returns array of sections or empty array if section creation failed.
Parameter | Type | Description |
---|---|---|
centerline | IndexedXYZCollection | centerline of pipe. For best results, ensure no successive duplicate points with e.g., createCompressed. |
sectionData | number | Readonly<WritableXAndY> | Arc3d | circle radius, ellipse semi-axis lengths, or full Arc3d (if not full, function makes it full). |
Returns - Arc3d[]
array of sections or empty array if section creation failed.
Defined in
- curve/CurveFactory.ts Line 425
Last Updated: 18 January, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.