createLineSpiralArcSpiralLine MethodStatic

Compute 2 spirals and an arc (all in XY) for a symmetric line-to-line transition. Spiral lengths and arc radius are given (e.g., from design speed standards).

createLineSpiralArcSpiralLine(spiralType: IntegratedSpiralTypeName, pointA: Point3d, pointB: Point3d, pointC: Point3d, lengthA: number, lengthB: number, arcRadius: number): undefined | GeometryQuery[]

@returns array with the computed spirals, or undefined if failure.

Parameter Type Description
spiralType IntegratedSpiralTypeName name of spiral type. THIS MUST BE AN "Integrated" SPIRAL TYPE.
pointA Point3d inbound start point.
pointB Point3d shoulder (target) point for (both) spiral-to-line tangencies.
pointC Point3d  
lengthA number inbound spiral length.
lengthB number outbound spiral length.
arcRadius number  

Returns - undefined | GeometryQuery[]

array with the computed spirals, or undefined if failure.

Defined in

Last Updated: 18 January, 2025