createArcPointTangentPoint MethodStatic
Create a circular arc defined by start point, tangent at start point, and end point.
- The circular arc is swept from start to end toward direction of the
tangentAtStart
. - If tangent is parallel to line segment from start to end, return
undefined
.
createArcPointTangentPoint(start: Point3d, tangentAtStart: Vector3d, end: Point3d): undefined | Arc3d
Parameter | Type | Description |
---|---|---|
start | Point3d | |
tangentAtStart | Vector3d | |
end | Point3d |
Returns - undefined | Arc3d
Defined in
- curve/CurveFactory.ts Line 111
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.