appendToArcInPlace MethodStatic
If arcB
is a continuation of arcA
, extend arcA
(in place) to include the range of arcB
- This only succeeds if the two arcs are part of identical complete arcs and end of
arcA
matches the beginning ofarcB
.
appendToArcInPlace(arcA: Arc3d, arcB: Arc3d, allowReverse: booleanfalse): boolean
@returns whether arcA
was modified
Parameter | Type | Description |
---|---|---|
arcA | Arc3d | first arc, modified in place |
arcB | Arc3d | second arc, unmodified |
allowReverse | boolean |
Returns - boolean
whether arcA
was modified
Defined in
- curve/CurveFactory.ts Line 245
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.