intersectionProjectedXYPairs MethodStatic
Return xy intersections of 2 projected curves.
- Curves can be extended if extend flags are set. B-splines are not extended even if the flag is set.
intersectionProjectedXYPairs(worldToLocal: Matrix4d, curveA: AnyCurve, extendA: boolean, curveB: AnyCurve, extendB: boolean, tolerance: numberGeometry.smallMetricDistance): CurveLocationDetailPair[]
Parameter | Type | Description |
---|---|---|
worldToLocal | Matrix4d | transform (possibly perspective) defining the local coordinates in which to compute xy intersections |
curveA | AnyCurve | first curve |
extendA | boolean | true to allow curveA to extend |
curveB | AnyCurve | second curve |
extendB | boolean | true to allow curveB to extend |
tolerance | number | optional distance tolerance for coincidence |
Returns - CurveLocationDetailPair[]
Defined in
- curve/CurveCurve.ts Line 51
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.