closeApproachProjectedXYPairs MethodStatic
Return at least one XY close approach between 2 curves.
- Close approach xy-distances are measured without regard to z. This is equivalent to their separation distance as seen in the top view, or as measured between their projections onto the xy-plane.
- If more than one approach is returned, one of them is the closest approach.
- If an input curve is a
CurveCollection
, then close approaches are computed to eachCurvePrimitive
child. This can lead to many returned pairs, especially when both inputs areCurveCollection
s. If an input curve is anAnyRegion
then close approaches are computed only to the boundary curves, not to the interior.
closeApproachProjectedXYPairs(curveA: AnyCurve, curveB: AnyCurve, maxDistance: number): CurveLocationDetailPair[]
Parameter | Type | Description |
---|---|---|
curveA | AnyCurve | first curve |
curveB | AnyCurve | second curve |
maxDistance | number | maximum xy-distance to consider between the curves. Close approaches further than this xy-distance are not returned. |
Returns - CurveLocationDetailPair[]
Defined in
- curve/CurveCurve.ts Line 111
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.