closestPoint Method

Search for the curve point that is closest to the spacePoint.

  • The CurveChainWithDistanceIndex invokes the base class CurvePrimitive method, which (via a handler) determines a CurveLocation detail among the children.
  • The returned detail directly identifies fractional position along the CurveChainWithDistanceIndex and has pointer to an additional detail for the child curve.

closestPoint(spacePoint: Point3d, extend: VariantCurveExtendParameter, result?: CurveLocationDetail): undefined | CurveLocationDetail

@returns details of the closest point

Parameter Type Description
spacePoint Point3d point in space
extend VariantCurveExtendParameter true to extend the curve
result CurveLocationDetail optional pre-allocated detail to populate and return.

Returns - undefined | CurveLocationDetail

details of the closest point

Defined in

Last Updated: 21 November, 2024