toScaledMatrix3d Method
Return the symmetric definition of the arc, with rigid axes and radii.
- The caller can send the returned data into createScaledXYColumns to construct the major-minor axis version of the instance arc. This formulation of the arc has the same shape, but has perpendicular axes, from which the arc's symmetry is readily apparent.
toScaledMatrix3d(): { axes: Matrix3d, center: Point3d, r0: number, r90: number, sweep: AngleSweep }
Returns - { axes: Matrix3d, center: Point3d, r0: number, r90: number, sweep: AngleSweep }
Defined in
- curve/Arc3d.ts Line 1074
Last Updated: 23 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.