setRefs Method
Redefine the arc with (captured references to) given data.
setRefs(center: Point3d, matrix: Matrix3d, sweep: AngleSweep): void
Parameter | Type | Description |
---|---|---|
center | Point3d | arc center. |
matrix | Matrix3d | matrix with columns vector0, vector 90, and their unit cross product. |
sweep | AngleSweep | angle sweep. |
Returns - void
Defined in
- curve/Arc3d.ts Line 297
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.