createCircularStartTangentEnd MethodStatic

Create a circular arc defined by start point, tangent at start point, and end point.

  • The circular arc is swept from start to end in the direction of tangentAtStart.
  • If tangentAtStart is parallel to the line segment from start to end, return the line segment.

createCircularStartTangentEnd(start: Point3d, tangentAtStart: Vector3d, end: Point3d, result?: Arc3d): LineSegment3d | Arc3d

Parameter Type Description
start Point3d  
tangentAtStart Vector3d  
end Point3d  
result Arc3d  

Returns - LineSegment3d | Arc3d

Defined in

Last Updated: 21 November, 2024