createCenterNormalRadius MethodStatic
Create a (full circular) arc from center, normal and radius.
createCenterNormalRadius(center: Point3d, normal: Vector3d, radius: number, result?: Arc3d): Arc3d
Parameter | Type | Description |
---|---|---|
center | Point3d | center of ellipse. If undefined, center at 000. |
normal | Vector3d | normal vector. |
radius | number | radius in x direction. |
result | Arc3d | optional preallocated result. |
Returns - Arc3d
Defined in
- curve/Arc3d.ts Line 358
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.