constructCircularArcChainApproximation Method
Construct a circular arc chain approximation to the instance elliptical arc.
constructCircularArcChainApproximation(options?: EllipticalArcApproximationOptions): undefined | Arc3d | CurveChain
@returns the approximating curve chain, the circular instance, or undefined if construction fails.
Parameter | Type | Description |
---|---|---|
options | EllipticalArcApproximationOptions | bundle of options for sampling an elliptical arc (use default options if undefined). |
Returns - undefined | Arc3d | CurveChain
the approximating curve chain, the circular instance, or undefined if construction fails.
Defined in
- curve/Arc3d.ts Line 1421
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.