cloneInRotatedBasis Method
Return an arc whose basis vectors are rotated by given angle within the current basis space.
- The returned arc will have
vector0 = this.vector0 * cos(theta) + this.vector90 * sin(theta)
. - The returned arc has the same shape as the instance.
- In other words, the arc's sweep is adjusted so that all fractional parameters evaluate to the same points.
- Specifically, theta is subtracted from the original start and end angles.
cloneInRotatedBasis(theta: Angle): Arc3d
Parameter | Type | Description |
---|---|---|
theta | Angle | the angle (in the input arc space) which is to become the 0-degree point in the new arc. |
Returns - Arc3d
Defined in
- curve/Arc3d.ts Line 1250
Last Updated: 18 January, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.