cloneAxisAligned Method

Return a cloned arc with basis rotated to align with the global axes. The arc's shape is unchanged.

  • This method is most useful when the instance is an xy-circular arc, for then the aligned arc's stored sweep angles can be understood as being measured from the global positive x-axis to the arc's start/end. This is not the case for xy-elliptical arcs: the parameter angle difference between two points on an ellipse is in general not the same as the angle measured between their radials.
  • For an xy instance, the output arc will have:
    • vector0 is in the same direction as the positive x-axis
    • perpendicularVector is in the same direction as the positive z-axis
  • For a general instance, the output arc will have:
    • vector0 is in the same direction as the projection of the positive x-axis vector onto the arc plane
    • perpendicularVector lies in the halfspace z >= 0

cloneAxisAligned(): undefined | Arc3d

@returns cloned arc, or undefined (if the instance normal is parallel to the x-axis, or its matrix is singular)

Returns - undefined | Arc3d

cloned arc, or undefined (if the instance normal is parallel to the x-axis, or its matrix is singular)

Defined in

Last Updated: 23 November, 2024