signedRadiansTo Method
Return the angle in radians (not as strongly-typed Angle) from this
vector to vectorB
, measured
in their containing plane whose normal lies in the same half-space as vectorW
.
- The returned angle is between
-Math.PI
andMath.PI
. - If the cross product of
this
vector andvectorB
lies on the same side of the plane asvectorW
, this function returnsradiansTo(vectorB)
; otherwise, it returns-radiansTo(vectorB)
. vectorW
does not have to be perpendicular to the plane.- Use
planarRadiansTo
to measure the angle between vectors that are projected to another plane.
signedRadiansTo(vectorB: Vector3d, vectorW: Vector3d): number
Parameter | Type | Description |
---|---|---|
vectorB | Vector3d | target vector. |
vectorW | Vector3d | determines the side of the plane in which the returned angle is measured |
Returns - number
Defined in
- geometry3d/Point3dVector3d.ts Line 1502
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.