safeDivideOrNull Method
Scale the instance by 1.0/denominator
.
safeDivideOrNull(denominator: number, result?: Vector3d): undefined | Vector3d
@returns scaled vector, or undefined if denominator
is exactly zero (in which case instance is untouched).
Parameter | Type | Description |
---|---|---|
denominator | number | number by which to divide the coordinates of this instance |
result | Vector3d | optional pre-allocated object to return |
Returns - undefined | Vector3d
scaled vector, or undefined if denominator
is exactly zero (in which case instance is untouched).
Defined in
- geometry3d/Point3dVector3d.ts Line 933
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.