rotate90Towards Method
Return a (new or optionally preallocated) vector that is rotated 90 degrees in the plane of this vector and the target vector.
rotate90Towards(target: Vector3d, result?: Vector3d): undefined | Vector3d
@returns rotated vector, or undefined if the cross product of this and the target cannot be normalized (i.e. if the target and this are colinear).
Parameter | Type | Description |
---|---|---|
target | Vector3d | Second vector which defines the plane of rotation. |
result | Vector3d | optional preallocated vector for result. |
Returns - undefined | Vector3d
rotated vector, or undefined if the cross product of this and the target cannot be normalized (i.e. if the target and this are colinear).
Defined in
- geometry3d/Point3dVector3d.ts Line 1097
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.